Alpaquita Linux
Security Advisory

CVE-2016-2167

Published: May 5, 2016Last modified: November 9, 2023

Description

The canonicalize_username function in svnserve/cyrus_auth.c in Apache Subversion before 1.8.16 and 1.9.x before 1.9.4, when Cyrus SASL authentication is used, allows remote attackers to authenticate and bypass intended access restrictions via a realm string that is a prefix of an expected repository realm string.

Severity score breakdown

ParameterValue
Base score6.8
Attack VectorNETWORK
Attack complexityHIGH
Privileges requiredLOW
User interactionNONE
ScopeUNCHANGED
ConfidentialityHIGH
Integrity impactHIGH
Availability impactNONE
VectorCVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N

Status

ProductReleasePackageStatus
Alpaquita Linux23 LTSsubversionNot affected (1.14.2-r5)
StreamsubversionNot affected (1.14.2-r12)

References

ON THIS PAGE